Getting consistent bluescreens, "wcifs.sys failed"
« on: December 16, 2017, 03:46:35 PM »
Hi, I've recently moved to One Commander V2 and I love it as a file manager. However, while the program is open, I consistently get a blue screen of death that crashes my entire computer, forcing a reboot. This does not appear to be linked to any particular activity, as the crashes often occur if One Commander is simply open in the background, not when it's doing anything specific.

The error message on the blue screen before Windows reboots references "wcifs.sys" as having failed. The issue persisted after a complete uninstall and reinstall of the program as well. Any thoughts on what may be causing it?

*

admin

  • *****
  • 543
  • Download at http://onecommander.com
    • onecommander.com
Re: Getting consistent bluescreens, "wcifs.sys failed"
« Reply #1 on: December 17, 2017, 10:10:29 PM »
Are you sure it is related to OC?
This is the first time I have heard of wcifs and seeing that it is related to "Windows Container Isolation" it could be something to do with UWP apps. You can try regular ClickOnce installer version from
http://onecommander.com/download.html
It is the same version but it is not packaged as an app

Re: Getting consistent bluescreens, "wcifs.sys failed"
« Reply #2 on: December 19, 2017, 06:16:44 PM »
It's almost certainly OC, as I had the problem on three different computers that previously had no blue screen errors and didn't have any when OC was not running. Between the three computers I had about 20 blue screen errors, all while OC was running.

The good thing is that the ClickOnce version appears to be working perfectly, and hasn't given me any errors at all in the last few days. You were exactly right. I'm not sure what part of my configuration was causing that problem with the UWP isolation, but I'm glad it's resolved!

Thanks for the quick response, and keep up the good work.

*

admin

  • *****
  • 543
  • Download at http://onecommander.com
    • onecommander.com
Re: Getting consistent bluescreens, "wcifs.sys failed"
« Reply #3 on: December 20, 2017, 11:52:33 AM »
Thanks for the update. Can you please tell me if you have any Shell Context Menu Extensions installed on those machines, or any thumbnail handler... anything that is in Windows's File Context menu that is not part of the original Windows installation?

Re: Getting consistent bluescreens, "wcifs.sys failed"
« Reply #4 on: December 20, 2017, 05:27:45 PM »
Ahhh good thought. I've got WinAero Tweaker running on all my machines, which does indeed include changes to context menu items, file explorer, and others.

I'll try disabling that then report back if I still have issues with the UWP version.

For now, I'm happy that I can use OC again though!