One Commander V2 has stopped working
« on: June 16, 2017, 03:07:10 AM »
Installer and Portable get this message upon install. Had Clover before.
Win7-x64 fully updated (.NET Framework 4.7)
Please advise.
Thanks.

*

admin

  • *****
  • 540
  • Download at http://onecommander.com
    • onecommander.com
Re: One Commander V2 has stopped working
« Reply #1 on: June 16, 2017, 09:28:52 AM »
If it shows that message instead of OC crash dialog it is something happening before the window was initialized. OC uses .NET 4.6 so please check first that you have that one installed also. It should also be in non-system folder, so not in program files.
If you did not run it before and have no OC settings to loose, delete folder
C:\Users\[yourusername]\AppData\Local\Rapidrive
Some badly written shell extensions could crash it at this stage also... for custom file previews or ones that add context menu items

Re: One Commander V2 has stopped working
« Reply #2 on: June 16, 2017, 01:22:46 PM »
Thanks for your reply.

1. Deleting C:\Users\[yourusername]\AppData\Local\Rapidrive does nothing apparent to fix the issue.

2. .NET 4.7 is part of windows update [kb3186497]

The Microsoft .NET Framework 4.7 is a highly compatible and in-place update to the Microsoft .NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2. 


*

admin

  • *****
  • 540
  • Download at http://onecommander.com
    • onecommander.com
Re: One Commander V2 has stopped working
« Reply #3 on: June 16, 2017, 02:16:54 PM »
Do you have any context menu extensions installed, window skinning programs, or are you running in virtual machine?
Try also extracting portable version in different directory and running as administrator.

Re: One Commander V2 has stopped working
« Reply #4 on: June 16, 2017, 02:27:56 PM »
Do you have any context menu extensions installed, window skinning programs, or are you running in virtual machine?
No. Had Clover installed by unistalled it once again and killed all explorer.exe processes before trying again with the portable version of OC.
EDIT2: Not sure if it qualifies as menu extension: ExtremeCopy

Try also extracting portable version in different directory and running as administrator.
Renamed the OC directory to portable1 and tried again (admin). Same result.
EDIT: Did exactly as told: unzip portable to a new directory. Same result.

Perhaps may consider a /debug key for following versions.

Thank you.
« Last Edit: June 16, 2017, 02:35:35 PM by alx359 »

Re: One Commander V2 has stopped working
« Reply #5 on: June 20, 2017, 03:33:55 PM »
The issue seems to be .Net 4.7 update. Had an Intel Graphics problem and rolled back to .NET 4.6.2. The OC (and Intel CP) issue are gone now.


*

admin

  • *****
  • 540
  • Download at http://onecommander.com
    • onecommander.com
Re: One Commander V2 has stopped working
« Reply #6 on: June 21, 2017, 10:25:08 AM »
Thanks for sharing.
I was hoping .NET 4.6.2 could be still installed even if 4.7 is there. I believe it used to be like that, several version coexisting on the same system and being properly used.
Unfortunately I cannot target 4.7 yet as most people probably don't have it.

Re: One Commander V2 has stopped working
« Reply #7 on: June 21, 2017, 10:41:48 AM »
I understand. .NET 4.7 has shown to all my Win7 boxes as an important/recommended Windows update since about a week ago, but still unchecked by default. So it's a matter of time now.